centos 安装nodejs v16 (低于node.js v18)

nodejs qmt 59℃

centos 安装nodejs 16

最新版的node可能装不了

centos 7 用yum search 搜索node.js 居然收不到对应的软件,只能用官网的源来安装了。

  1. step1 :
    curl --silent --location https://rpm.nodesource.com/setup_14.x | bash
    (setup_14里14是版本号,可根据自己需要修改)
    curl --silent --location https://rpm.nodesource.com/setup_16.x | bash

  2. step2:
    运行安装命令:
    yum -y install nodejs

  3. 遇到的问题:

  • 如果你输入了很多次上面的不同nodejs版本的命令,比如输入;
    curl --silent --location https://rpm.nodesource.com/setup_14.x | bash

  • 之后,又继续输入:
    curl --silent --location https://rpm.nodesource.com/setup_16.x | bash

  • 然后有继续输入了:
    curl --silent --location https://rpm.nodesource.com/setup_18.x | bash

  • 那么本地存在多个nodesoucre,可以执行以下命令,在重新yum安装命令
    yum clean all
    rm -fv /etc/yum.repos.d/nodesource*

然后再次输入上述某一个版本的命令即可:
curl --silent --location https://rpm.nodesource.com/setup_18.x | bash

转载请注明:QMT|Ptrade量化交易 » centos 安装nodejs v16 (低于node.js v18)

喜欢 (0)